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About This Documentation
This documentation describes the tools available for GemBuilder for Java® for 
Java™ 3.0, an integrated environment for programming GemStone® Smalltalk 
applications. These tools consist of the following:

 • A GemStone Browser for examining, creating, and modifying GemStone classes 
and methods.

 • A Workspace for running small pieces of GemStone Smalltalk.

 • An Inspector for examining and modifying the state of GemStone objects.

 • A Debugger for examining and modifying an execution stack created by 
GemStone Smalltalk execution.

 • A Class Version Browser for examining a class history, inspecting instances, 
migrating instances, deleting versions, and moving versions to another class 
history.

 • A Breakpoint Browser for enabling, disabling, and removing breakpoints in 
methods, as a debugging aid examining a class history, inspecting instances, 
migrating instances, deleting versions, and moving versions to another class 
history.
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GemBuilder for Java tools may be used against both GemStone/S, the 32-bit server 
product, and GemStone/S 64 Bit. While the server products are similar, some 
features differ. GemBuilder for Java behavior that depends on server behavior may 
therefore vary depending on which server product and version you are running 
with. In this documentation, the term “GemStone” is used when behavior is 
common; server specific differences are noted when necessary.

Assumptions
To make use of the information in this documentation, you need to be familiar with 
the GemStone server and with the GemStone Smalltalk programming language as 
described in the Programming Guide for your GemStone server product. That book 
explains the basic concepts behind the language and describes the most important 
GemStone kernel classes. 

This documentation assumes that the GemStone system has been correctly 
installed on your host computer as described in the GemStone System 
Administrator’s Guide, and that GemBuilder for Java has been installed and 
configured according to the GemBuilder for Java Installation Guide.

How This Manual is Organized
The Launcher explain how to communicate with the GemStone object server by 
initiating a GemStone session and use the Launcher tool to access the various tools.

The Browsers explains how to use the GemStone browsers and tools to create 
classes and methods in the GemStone server.

Related Tools describes how to use the GemStone workspace, inspectors, and the 
debugging tool with your GemStone Smalltalk code.

Other Useful Documents
 • The Javadocs that are provided with the GemBuilder for Java product 

distribution are a key source of up-to-date information on GemBuilder for Java 
functionality.

 • The GemBuilder for Java Programming Guide, which is provided in .pdf form 
with your GemBuilder for Java installation.

 • The Programming Guide for GemStone/S or GemStone/S 64 Bit describes the 
GemStone System and the GemStone Smalltalk language.
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 • If you will be acting as a system administrator, or developing software for 
someone else who must play this role, you should read the System 
Administration Guide for GemStone/S or GemStone/S 64 Bit.

Technical Support
GemStone’s Technical Support website provides a variety of resources to help 
you use GemStone products. 

GemStone Web Site: http://support.gemstone.com
Use of this site requires an account, but registration is free of charge and provides 
immediate access. 

All GemStone product documentation is provided in PDF form on this website. 
Documentation is also available at 

http://www.gemstone.com/documentation
In addition to documentation, the support.gemstone.com website provides:

 • Bugnotes, identifying performance issues or error conditions that you may 
encounter when using a GemStone product.

 • TechTips, providing information and instructions that are not otherwise 
included in the documentation.

 • Compatibility matrices, listing supported platforms for GemStone server 
product versions.

This material is updated regularly; we recommend checking this site on a regular 
basis.

Help Requests
You may need to contact Technical Support directly, if your questions are not 
answered in the documentation or by other material on the Technical Support 
site. 

Requests for technical assistance may be submitted online, or by email or by 
telephone. We recommend you use telephone contact only for more serious 
requests that require immediate evaluation, such as a production system down. 
The support website is the preferred way to contact Technical Support.

Website: http://techsupport.gemstone.com
Email: support@gemstone.com
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Telephone: (800) 243-4772 or (503) 533-3503
Your GemStone support agreement may identify specific designated contacts 
who are responsible for submitting all support requests to GemStone. If so, please 
submit your information through those individuals.

If you are reporting an emergency by telephone, select the option to transfer your 
call to the Technical Support administrator, who will take down your customer 
information and immediately contact an engineer. Non-emergency requests 
received by telephone will be placed in the normal support queue for evaluation 
and response.

When submitting a request, please include the following information:

 • Your name, company name, and GemStone server license number.

 • The versions of all related GemStone products, and of any other related 
products, such as client Smalltalk products.

 • The operating system and version you are using.

 • A description of the problem or request.

 • Exact error message(s) received, if any, including log files if appropriate.

Technical Support is available from 8am to 5pm Pacific Time, Monday through 
Friday, excluding GemStone holidays.

24x7 Emergency Technical Support
GemStone offers, at an additional charge, 24x7 emergency technical support. This 
support entitles customers to contact us 24 hours a day, 7 days a week, 365 days a 
year, for issues impacting a production system. For more details, contact your 
GemStone account manager.

Training and Consulting
Consulting and training for all GemStone products are available through 
GemStone’s Professional Services organization. GemStone periodically offers 
training courses at our offices in Beaverton, Oregon, or training can be arranged 
at your location. Contact your GemStone account representative for more details 
or to obtain consulting services.
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1 The Launcher

Overview
The GemBuilder for Java Tools are Java applications that make use of the 
underlying GemBuilder for Java application programming interface. You can use 
these tools by themselves, or you can integrate them into popular Java 
development environments like Sun's Java Workshop and Symantec Café.
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Launching the Tools 
The GemStone Launcher window lets you log in to a GemStone server, which 
gives you access to the GemStone Smalltalk compiler and the GemBuilder for Java 
Tools. Initially, only the Login… and Workspace buttons are enabled. The lower 
pane, the text pane, serves as a transcript for system messages. 

Figure 1.1   GemStone Tools Launcher

You can run the Launcher as a stand-alone Java application within a Web browser.

To Start a Standalone Launcher
To start the Launcher as a standalone application, invoke the Java runtime system 
from an operating system command prompt.

You must have set up the client environment correctly to ensure access to the 
correct server shared libraries, and set the CLASSPATH environment variable to 
include the location of gbj30.jar, and gbjopensrc30.jar, as described in the 
documentation for your Java system and the GemBuilder for Java Installation Guide.

To invoke the Launcher, for example, on a 32-bit system:

prompt> java com.gemstone.tools.GbjLauncher

or on a 64-Bit system:

prompt> java -d64 com.gemstone.tools.GbjLauncher
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Logging in to GemStone
After the Launcher appears, the next step ordinarily is to log in to a GemStone 
server. Click the Login… button in the Launcher, which opens a dialog in which 
you identify the GemStone server and provide the GemStone userId, password, 
and other relevant information (the client can provide this information 
programmatically). Use the mouse or Tab key (not Return) to move between fields.

Figure 1.2   Login Dialog

NOTE:  
After you log in, all tools you start will run under that GemStone session. To 
run tools under a different session, start the Launcher again.

Parameter Explanation

GemStone Server The name of the GemStone server, such as 
“gs64stone”. This field can include the name of 
server's machine using Network Resource String 
(NRS) syntax; for instance, “!@handel!gs64stone”. 
GemBuilder for Java must be installed on the server.

GemStone User The GemStone userId under which you want to log in 
(must already exist in the server)

GemStone Password The password for the GemStone userId
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For information about Network Resource Syntax and the NetLDI, see the System 
Administration Guide for your server product.

The Launcher
The Launcher not only lets you log in to a GemStone server, but also gives access 
to the other Tools:

• GemStone Browsers and specialized browsers derived from it

• Workspaces

• Inspectors 

The Launcher contains a text pane that serves as both a session transcript and as a 
workspace. The transcript records significant events, such as logins, commits, and 
logouts. Clicking Help displays version information in the transcript.

Gem Service 
(optional)

The name of the Gem service to be used. By default, 
you can use “gemnetobject”; users of the UNIX C 
Shell may prefer “gemnetobjcsh” (not available with 
GemStone/S 64 Bit). 

Host User An operating system login name on the machine 
where the Stone is running. This user name and 
password are required to start a separate Gem 
process unless your GemStone installation uses 
another method of providing network authentication, 
such as a .netrc file or running NetLDIs in guest 
mode with a captive account.

Host Password The operating system password for the Host User on 
the machine where the Stone is running

Transaction Mode Choose Automatic if you are going to be committing 
changes to the server. Choose Manual if your primary 
activity will be reading the committed state; before 
making a change you want to commit, begin a 
transaction manually by choosing Session > Begin 
in the GemStone Browser. (For more information, see 
the GemBuilder for Java Programming Guide or the 
Programming Guide for your server product)
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Figure 1.3   Session Transcript in Launcher Text Pane

The Launcher Buttons
Five Launcher buttons provide convenient access to frequently used functions: 
Login/Logout, Browser, Workspace, Senders…, and Implementors… .

The Login button opens a dialog through which you enter session parameters and 
log in to the GemStone server, as described in ”Logging in to GemStone” on page 
11. When the login attempt succeeds, the label on this button changes to Logout.

The Browser button opens a GemStone Browser through which you can examine, 
create, or modify Smalltalk classes and methods in the server. For further 
information, see ”The Browsers” on page 2-19. This button is enabled only when 
you are logged in to the server.

The Workspace button opens a text area in which you can evaluate GemStone 
Smalltalk expressions or edit text. This button is always enabled, but to evaluate 
expressions, you must be logged in to the server.

The Senders… button prompts for a method name, then opens a Method List 
Browser showing all visible server methods that send the specified message. For 
further information, see ”The Method Browser” on page 30. This button is enabled 
only when you are logged in to the server.

The Senders… and Implementors… buttons search the methods visible in the 
session's symbol list. For more information about how GemStone uses the symbol 
list for name resolution, see ”The Symbol List Pane” on page 20 and the GemStone/S 
Programming Guide.
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You can use wild-card characters in the search dialog associated with Senders… 
and Implementors…. A “*” matches any number of characters, and “?” matches a 
single character. 

The Launcher Menus
The Launcher menus provide commands for executing GemStone Smalltalk code 
and accessing the GemStone Tools.

The File Menu
The File menu contains these items:

Open... Requests a file name, then copies the contents into the 
workspace (transcript)

Save As... Requests a file name, then writes the contents of the 
workspace (transcript) into the specified file

File In… Opens a file dialog allowing you to specify a source 
code file. Treats the selected file as being in GemStone 
file-in format, and files it in.

Settings Opens a dialog that allows you to specify a font and 
font style; and allows you to set verbose client logging 
On or Off for the client and server. Changes affect the 
Launcher and any tools you open subsequently.

Exit Kills the Tools application, closing all open browsers, 
inspectors, and so forth. The GemStone session is 
terminated. 
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The Edit Menu
The Edit menu contains these items:

The Session Menu
The Session menu contains these items:

Cut Cuts the currently selected text from the text pane and 
puts it in the clipboard.

Copy Copies the currently selected text from the text pane 
and puts it in the clipboard.

Paste Pastes the text from the clipboard at the current 
selection position in the text pane.

Select All Selects all of the text in the text pane
Do-It Uses the GemStone compiler to evaluate and execute 

the currently selected text
Print-It Performs a Do-It, sends the resulting object the 

message printString, then places the resulting string 
after the current text pane selection

Inspect-It Performs a Do-It, and then opens a GemStone 
Inspector on the resulting object

File It In Treats the selected text as being in GemStone file-in 
format, and files it in.

Login… If there is no Launcher session, opens a login dialog and 
lets you log in to GemStone (same as clicking the Login… 
button)

Logout Logs out the Launcher session, if there is one (same as 
clicking the Logout button)

Commit Commits the Launcher session
Abort Aborts (rolls back) the Launcher session
Begin Begins a new transaction
Manual Switches the Launcher session to manual transaction mode
Auto Switches the Launcher session to automatic transaction 

mode
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The Tools Menu
The Tools menu contains these items:

You can use wild-card characters in the search dialog associated with Senders, 
Implementors, Browse Class, and Browse Hierarchy. A “*” matches any 
number of characters, and “?” matches a single character. 

Browser Opens a GemStone System Browser (same as clicking 
the Browser button)

Workspace Opens a GemStone workspace in which you can 
execute Smalltalk expressions (same as clicking the 
Workspace button)

Senders Requests a selector name, then opens a Method List 
Browser showing all senders of that message (same as 
clicking the Senders… button)

Implementors Requests a selector name, then opens a Method List 
Browser showing all implementors of that message 
(same as clicking the Implementors… button)

References Requests a symbol and then opens a Method List 
Browser showing all methods that refer to that 
symbol, including all references to associations with 
the specified symbol as the key. 

Find Substring Requests a string, and then opens a Method List 
Browser showing all methods that contain the 
specified string in their source code. The search is 
case-sensitive. If no such string is found, opens a 
notifier instead.

Browse Class Requests a class name, then opens a Class Browser on 
the class

Browse Hierarchy Requests a class name, then opens a Hierarchy 
Browser on the class

Breakpoints Opens a Breakpoint Browser.
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The Windows Menu
The Windows menu contains these items:

Hide All Hides all windows.
Show All Shows all windows.
<name of each 
open window>

Each open window has an entry in the menu. You can 
show an individual window by clicking that window in the 
Windows menu.
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2 The Browsers

The GemStone Browser
After you have successfully logged in to GemStone, you can open a GemStone 
Browser by choosing Tools > Browser or by clicking the Browser button in the 
Launcher. The GemStone Browser lets you create classes and methods in the server 
using GemStone Smalltalk. 
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Figure 2.1   GemStone Browser

The Symbol List Pane
The upper left pane contains a list of symbol dictionaries. In GemStone, the named 
objects to which your programs refer (the classes and root or global objects) are 
listed in symbol dictionaries. This list facilitates finding objects efficiently as well 
as sharing them among users. All of the symbol dictionaries that you can access in 
your current session environment are listed in the GemStone Browser’s Symbol 
List pane.

When you select a symbol dictionary, all classes defined in that dictionary appear 
in the pane to the right of the Symbol List pane. (Symbols other than classes can be 
viewed by opening an inspector on the symbol dictionary in question.)

For further information about symbol lists, see the GemStone/S Programming Guide.

The Classes Pane
When you select a class from the Classes pane, a list of its protocols appears in the 
Protocol pane adjacent on the right. In GemStone, methods are categorized by 
function, or protocol, to make them easier to browse. 

Symbol
Dictionaries

Classes Protocol
Categories

Method
Selectors

Text
Pane
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The Protocol Pane
When you select a protocol, all the message selectors in that category appear in the 
Method Selectors pane at the far right.

You can switch the focus of the display between instance methods or class 
methods by using the radio buttons provided.

The Text Pane
When you select a method, its source code is displayed in the lower portion of the 
browser—the text pane. In this pane, you can edit and recompile the text of the 
displayed method, or execute fragments of GemStone Smalltalk code as in a 
workspace.

The Browser Menus

The File Menu
The following commands are available in the File menu:

The Edit Menu
The Edit menu contains these items:

Update Updates the browser to match the current state of the 
Launcher's session. This action may change the contents 
of the browser because of changes made in other tools.

Close Close the browser window.

Cut Cuts the currently selected text from the text pane and 
puts it in the clipboard.

Copy Copies the currently selected text from the text pane and 
puts it in the clipboard.

Paste Pastes the text from the clipboard at the current selection 
position in the text pane.

Select All Selects all of the text in the text pane
Do-It Uses the GemStone compiler to evaluate the currently 

selected text
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The Session Menu
The Session menu contains these items:

If an attempted commit fails, choose Report in the resulting dialog to open a 
GemStone Inspector through which you can determine the cause of the failure. The 
inspector is on the result of invoking System Class >> 
transactionConflicts in the server.

Print-It Performs a Do-It, sends the resulting object the message 
printString, then places the resulting string after the 
current text pane selection

Inspect-It Performs a Do-It, then opens a GemStone Inspector on 
the resulting object

Compile Compiles the current text in the text pane. Use this choice 
to create a new class or method, or to modify existing 
definitions.

Cancel Cancels any text entry done in the text pane, and returns 
the method definition, class definition, and so forth, to its 
unmodified form

Set Break Sets a breakpoint at the current insertion point in the 
current method.

Commit Commits the Launcher session
Abort Aborts (rolls back) the Launcher session
Begin Begins a new transaction
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The Dictionary Menu
The Dictionary menu contains these items:

The Class Menu
The Class menu is active only when a class has been selected. The following 
commands are available from the Class menu.)

File Out As Requests a file name, then creates a fileout (.gs file) 
containing the classes and methods in the selected 
symbol dictionary.

Inspect Opens a GemStone Inspector on the currently selected 
symbol dictionary.

Add Requests a new dictionary name, then adds a new 
symbol dictionary by that name to your symbol list.

Rename As Requests a new dictionary name, then renames the 
selected symbol dictionary to that name.

Remove After confirmation, removes the selected symbol 
dictionary from your symbol list.
WARNING: Do not try to remove the Globals dictionary. The 
Globals dictionary defines the GemStone kernel classes.

Find Class Requests a class name, then selects the matching symbol 
dictionary and class entry in the class list.

File Out As... Requests a file name, then creates a fileout (.gs file) 
containing the selected class and its methods

Browse > Class Opens a Class Browser on the selected class
Browse > Hierarchy Opens a Class Hierarchy Browser on the selected class.
Browse > Versions Opens a Class Version Browser on the selected class. The 

browser shows how many versions of that class exist.
References To > 
Instance Variable

Opens a selection dialog allowing you to choose from a 
list of instance variables of the selected class. Choose one 
and click OK or press Return, and a Method List Browser 
opens showing all methods that refer to the selected 
instance variable.
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References To > 
Class Variable

Opens a selection dialog allowing you to choose from a 
list of class variables of the selected class. Choose one and 
click OK or press Return, and a Method List Browser 
opens showing all methods that refer to the selected class 
variable.

References To > 
Class

Opens a Method List Browser showing all methods that 
refer to the selected class.

Show > Hierarchy
Show > Definition Displays the class definition of the selected class in the 

text pane.
Show > Comment Displays the class comment of the currently selected 

GemStone-supplied class
Move to Lets you choose another symbol dictionary, then moves 

the selected class to that dictionary.
Remove After confirmation, removes the selected class from its 

associated symbol dictionary
CAUTION: To avoid inadvertently removing or modifying a 
GemStone kernel class, use the DataCurator account for all 
administrative tasks except those that require SystemUser 
privileges, such as upgrading the repository.

New Template Presents a class definition template in the text pane.
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The Protocol Menu
To help you organize your work, GemStone Smalltalk methods that are 
functionally similar are grouped together into protocol categories with descriptive 
names, such as initializing, accessing, or updating. These categories are descriptive 
only; they do not affect the operation of GemStone Smalltalk in any way. 

The following items are available in the Protocol menu. (Until you’ve selected a 
method category, Add is the only menu item enabled.)

The Method Menu
The Method menu allows you to file out a single method, reorganize methods into 
different categories, and remove a method. Items in the Method menu are 
available only when a method has been selected.

Add Requests a protocol name, then adds the protocol to the 
selected class.

Rename As Requests a protocol name, then renames the selected 
protocol to that name.

Remove Removes the selected protocol (after confirmation, if it 
contains any methods).

Find Method Provides a list of all method names in the selected class, 
then updates the protocol and method panes to show the 
selected protocol and method.

File Out As Requests a file name, then creates a fileout (.gs file) 
containing the selected method.

Browse Method Opens a GemStone Method Browser on the selected 
method.

Senders Opens a GemStone Method List Browser showing all 
senders of the selected method (same as clicking the 
Senders… button in the Launcher and entering the name 
of the method).

Implementors Opens a GemStone Method List Browser showing all 
implementors of the selected method (same as clicking 
the Implementors… button in the Launcher and entering 
the name of the method).
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Messages After you choose one of the messages sent by the selected 
method, opens a GemStone Method List Browser 
showing all implementors.

Move to Requests the name of a protocol to which the selected 
method should be moved, then moves the method. If no 
protocol exists by the name supplied, this menu item 
adds the protocol and then does the move.

Remove After confirmation, removes the selected method.
View > Class Only Displays protocols and methods for the selected class 

only. The selected view persists when you select a new 
class.

View > Up To Root Displays protocols and methods for the selected class and 
all superclasses up to, but not including, the class at the 
root of the hierarchy (typically Object). The selected view 
persists when you select a new class.

View > Including 
Root

Displays protocols and methods for the selected class and 
all superclasses, including the class at the root of the 
hierarchy (typically Object). The selected view persists 
when you select a new class.

New Template Presents a new method template in the text pane.
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Specialized Browsers
GemBuilder for Java Tools implement several specialized browsers based on the 
GemStone Browser: the Class Browser, Hierarchy Browser, Class Version Browser, 
Method Browser, Method List Browser, and Breakpoint Browser.

The Class Browser
The GemStone Class Browser displays a single GemStone class. The menu items 
supported by the browser are the same as those supported by the System Browser 
except the Dictionary menu is not available. Open this browser by choosing Class 
> Browse > Class in the GemStone Browser or by choosing Tools > Browse 
Class in the GemStone Launcher.

You can use wild-card characters in searches, with “*” matching any number of 
characters, and “?” matching a single character. 

Figure 2.2   Class Browser
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The Hierarchy Browser
The GemStone Hierarchy Browser displays the superclass chain of a target class 
plus all subclasses of the target class. For example, choosing Class > Browse > 
Hierarchy when class HR_Engineer is selected allows you to browse the 
hierarchy for that class, which happens to be a direct subclass of Object. The menu 
items supported by the browser are the same as those supported by the System 
Browser, except the Dictionary menu is not available.

You can use wild-card characters in searches, with “*” matching any number of 
characters, and “?” matching a single character. 

Figure 2.3   Class Hierarchy Browser
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The Class Version Browser
The GemStone Class Version Browser displays the versions of a class in the class 
history of the target class. For example, doing Class > Browse Versions when 
class HR_HelpRequest is selected in the GemStone Browser shows two versions 
exist. You can select either version in the left pane. The browser displays the 
definition of the selected version in the text pane. 

Figure 2.4   Class Version Browser

The menu items supported by the Class Version Browser are generally the same as 
those supported by the System Browser. The Class menu has been extended, and 
several of the menu items have slightly different semantics. The additional and 
altered items in the Class menu are these:

Class > Move to Requests the name of a target class, then moves the 
selected class version to the class history of the 
target class.

Class > Remove After confirmation, removes the selected class 
version from its class history.

Class > Inspect 
Instances

Opens a GemStone Inspector on all instances of the 
currently selected class version. Because this 
operation can be lengthy, you are asked to confirm 
your intent.
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The Method Browser
The Method Browser displays an individual method. For example, invoking the 
Method browser on HR_Engineer > email shows its definition. 

Figure 2.5   Method Browser

The supported menu items are the same as those for the other browsers except the 
Dictionary, Class and Protocol menus are not available.

The Method List Browser
The Method List Browser displays a list of methods defined in various classes. The 
browser is used to display senders and implementors of various messages. For 
example, invoking the menu item Implementors on firstName: lets you browse 
each implementation of that message. The same list can be obtained by clicking the 
Implementors… button in the GemStone Launcher.

You can use wild-card characters in searches, with “*” matching any number of 
characters, and “?” matching a single character. 

Class > Migrate 
Instances

After you choose a target class version, migrates all 
instances of the selected version to the target 
version.
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Figure 2.6   Implementors of a Particular Method

The Breakpoint Browser
The Breakpoint Browser displays a list of methods for which breakpoints have 
been specified. Open it using the Tools > Breakpoints menu item in the 
GemStone Launcher. You can then select a breakpoint and enable, disable, or 
remove it.

To set a breakpoint:

1. Open any tool that allows you to browse method source code. 

2. Place the insertion point before the point at which you wish execution to halt.

3. Select Edit > Set Break. 

When a breakpoint is encountered, a notifier allows you to open a debugger. See 
”The Debugger” on page 40.
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The Breakpoint Browser appears as shown below:

Figure 2.7   Viewing Breakpoints

The top pane contains a list of all breakpoints set in GemStone Smalltalk code. The 
bottom pane shows the source for the selected breakpoint, highlighting the 
message-send at which execution will stop when the breakpoint is encountered.

Breakpoint Browser Buttons

Four buttons provide convenient access to the main functions of the Breakpoint 
Browser.

The Update button updates the Breakpoint Browser in case breakpoints have been 
set in another tool since the browser was opened.

The Remove button removes the selected breakpoint.

The Enable button enables the selected breakpoint, causing execution to stop 
when it is reached. 

The Disable button disables the selected breakpoint without removing it. 
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Breakpoint Menu

The Breakpoint Browser offers one new menu, the Breakpoint menu. It contains 
these items: 

Remove Break Removes the currently selected breakpoint from the 
browser and the system. This is the same as clicking the 
Remove button.

Enable Break Enables the currently selected breakpoint, causing 
execution to halt when it is reached. This is the same as 
clicking the Enable button.

Disable Break Disables the currently selected breakpoint, causing 
execution to continue uninterrupted when it is reached, 
but leaving the breakpoint in both the system and the 
browser for possible future use. This is the same as 
clicking the Disable button.

Remove All 
Breaks

Removes all breakpoints from the browser and the 
system.

Enable All Breaks Enables all breakpoints, causing execution to halt when 
they are reached.

Disable All 
Breaks

Disables all breakpoints, causing execution to continue 
uninterrupted when they are reached, but leaving them 
in both the system and the browser for possible future 
use.
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3 Related Tools

Overview
Three additional tools provide assistance in working with GemStone Smalltalk:

• Workspaces are text areas in which Smalltalk expressions can be evaluated. You 
can also use a workspace to file in code previously saved from GemStone.

• Inspectors let you examine GemStone objects, including the result of evaluating 
an expression in a workspace.

• The Debugger lets you inspect the state of Smalltalk execution at the time of an 
error.

In addition, certain menus and keyboard shortcuts are common to all the tools. 
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The Workspace
The GemStone Workspace provides a text area in which expressions can be 
evaluated. For example, you can evaluate the expression

HR_Customer allCustomers 

by highlighting the expression and then choosing Edit > Print-It or a similar menu 
item.

Figure 3.1   A Workspace

The menu items available in the Workspace menu are similar to those in the 
Browser and Launcher:

File > Open Requests a file name, then copies the contents into the 
workspace.

File > Save As Requests a file name, then writes the contents of the 
workspace into the specified file.

File > File In Opens a file dialog allowing you to specify a source code 
file. Treats the selected file as being in GemStone file-in 
format, and files it in.

File > Close Closes the workspace.
Edit > Cut Cuts the currently selected text from the text pane and 

puts it in the clipboard.
Edit > Copy Copies the currently selected text from the text pane and 

puts it in the clipboard.
Edit > Paste Pastes the text from the clipboard at the currently 

selected position in the text pane.
Edit > Select All Selects all of the text in the text pane.
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The Inspector
When you select a GemStone Smalltalk expression and execute Inspect-It from the 
Edit menu, a GemStone Inspector opens. This inspector contains two panes, which 
enable you to examine and modify the values of instance variables in the 
GemStone server object returned as the result of the expression. 

The left pane lists self, which refers to the inspected object, together with the 
names or indexes of the object’s instance variables. (If the object is an instance of a 
Dictionary, the left pane lists the keys). When you select an item in the left pane, 
the right pane shows the value of that item. For example, invoking an Inspector on 
the expression HR_Customer allCustomers produces this inspector:

Edit > Do-It Uses the GemStone compiler to evaluate the currently 
selected text.

Edit > Print-It Performs a Do-It, sends the resulting object the message 
printString, and then places the resulting string after the 
current text pane selection.

Edit > Inspect-It Performs a Do-It, then opens a GemStone Inspector on 
the resulting object.

Edit > File-It In Treats the selected text as though it is in GemStone file-
in format, and tries to file it in to the GemStone server.

Session > Commit Commits the Launcher’s session.
Session > Abort Aborts the Launcher’s session.
Session > Begin Begins a new transaction.
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Figure 3.2   An Inspector

You can use the right pane to execute GemStone Smalltalk expressions that contain 
names appearing in the left pane. For example, if the inspected object had an 
instance variable named count whose value was 5, then executing the expression 
count * 5 in the right pane returns the value 25.

The menu items supported by the GemStone Inspector are shown below.

File > Update Updates the inspector to match the current state of the 
Launcher’s session. 

File > Close Closes the inspector window.
Edit > Cut Cuts the currently selected text from the text pane and 

puts it in the clipboard.
Edit > Copy Copies the currently selected text from the text pane 

and puts it in the clipboard.
Edit > Paste Pastes the text from the clipboard at the current 

selection position in the text pane.
Edit > Select All Selects all of the text in the text pane.
Edit > Do-It Uses the GemStone compiler to evaluate the currently 

selected text.
Edit > Print-It Performs a Do-It, sends the resulting object the 

message printString, and then places the resulting 
string after the current text pane selection.

Edit > Inspect-It Performs a Do-It, then opens a GemStone Inspector on 
the resulting object.
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Inspecting Dictionaries and Sets
When you inspect a Dictionary and select an association in the left pane, its value 
is shown in the right pane. For example, opening the inspector on the 
HelpRequestSystem SymbolDictionary and selecting #HR_Customer shows 
the value, the HR_Customer class.

Figure 3.3   Inspecting a Dictionary

Edit > Compile Compiles the current text in the text pane. The text in 
the text pane is evaluated, and the resulting object is 
assigned to the selected slot of the object being 
inspected. 

Edit > Cancel Cancels any text entry done by the user in the text 
pane, and return the inspector text pane to its 
unmodified form (which may be to show the 
printString of the selected slot).

Session > Commit Commits the Launcher’s session.
Session > Abort Aborts the Launcher’s session.
Session > Begin Begins a new transaction.
Variables > Inspect Opens a new inspector on the selected item from the 

inspector list pane.
Variables > More Retrieves more of the object's indexable fields. By 

default, the first 100 are retrieved. Each pick of this 
menu item doubles the number of fields that are 
retrieved.
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When you inspect the Set returned by evaluating HR_Engineer allEngineers, 
the elements (the engineers' login names) are shown in the left pane.

Figure 3.4   Inspecting a Set

The Debugger
The Debugger can be invoked either from an error notifier or by encountering a 
breakpoint while running code from a workspace.

For example, the following sequence results from evaluating the expression 

Array new at: 1

with Do-It in a workspace. When the error notifier appears, clicking the Debug 
button brings up a Debugger. 
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Figure 3.5   Debugger

The debugger consists of six panes. At the top is the stack pane, which shows the 
stack as it was when execution halted do to an error or breakpoint. Select a specific 
message in the stack, and the source pane below shows the source code associated 
with it. 

The bottom four panes are actually two inspectors.   The inspector on the left lists 
the receiver and instance variables of the selected message. Selecting one causes its 
value to appear in the pane directly to the right. The inspector on the right lists the 
variables referred to in the selected message. Selecting one causes its value to 
appear in the rightmost pane.
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Debugger Buttons
Four debugger buttons provide convenient access to common debugging 
functions.

Step Over steps process execution over the next message-send highlighted in the 
source pane. Control then returns to the debugger with the next step point 
highlighted.

Step Into steps process execution into the next message-send highlighted in the 
stack pane. Control typically returns to the debugger with a new message on top 
of the stack. Execution is halted at the beginning of the new method in the source 
pane.

Continue continues executing the process and closes the debugger. 

Trim Stack trims messages from the stack, starting at the top and trimming until 
the selected message is reached. The next step point is at the beginning of the new 
top of the stack.

Debugger Menus
The debugger File, Edit, Session, and Method menus are all similar to those in 
other tools. The Process menu contains these items:

Step Over Steps process execution over the next message-send 
highlighted in the source pane. Control then returns to 
the debugger with the next step point highlighted. This 
is the same as clicking the Step Over button.

Step Into Steps process execution into the next message-send 
highlighted in the stack pane. Control typically returns 
to the debugger with a new message on top of the stack. 
Execution is halted at the beginning of the new method 
in the source pane. This is the same as clicking the Step 
Into button.

Explain Prints the original descriptive error text in the source 
pane. 

Continue Continues executing the process and closes the 
debugger. This is the same as clicking the Continue 
button.
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The Receiver and Context menus have one item each:

Invoking the Debugger from a Workspace
The ordinary way to invoke the debugger is to set a breakpoint in your Smalltalk 
code, then invoke that code by evaluating an expression in the workspace. For 
example:

1. Set the breakpoint:

a. Open any source code browser on the appropriate class, such as 
HR_Engineer. 

b. Select the desired protocol and method. 
c. Place the insertion point before the place where you want execution to 

halt, then choose Edit > Set Break. (To view existing breakpoints, see 
page 31.)

2. Open a workspace and enter an expression that invokes code where the 
breakpoint is set. Select the expression and choose Edit > Do-It.

3. When the breakpoint notifier appears, click Debug. (Continue continues the 
current process without opening the debugger. Terminate ends the current 
process.

Trim Stack Trims messages from the stack, starting at the top and 
trimming until the selected message is reached. The next 
step point is at the beginning of the new top of the stack. 
This is the same as clicking the Trim Stack button.

Copy Stack Creates a text representation of the stack, as seen in the 
stack pane, and places it in the clipboard.

Inspect Opens an Inspector on the value selected in the leftmost 
bottom pane, in the case of the Receiver menu, or the 
bottom pane second from the right, in the case of the 
Context menu.
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Figure 3.6   Debugging Engineer | withEmailName:

Invoking the Debugger from Your Java Client
To invoke the debugger from your running application, you must set a breakpoint 
within Smalltalk code that is called within a Java try block. When the GemStone 
server encounters the breakpoint, it returns an exception to the client. The catch 
block uses the exception as an argument to open an instance of GbjDebugger. For 
example, this sequence stops at a breakpoint in HR_Engineer | 
email:firstName:lastName:phone:

1. Find the Java code that calls the Smalltalk code in which the breakpoint will be 
set. Open a GbjDebugger in the catch block for that code.

try {
eng = (HR_Engineer) engClass.perform(

"email:firstName:lastName:phone:", args, 4);
} catch (GbjEventException e) {

new com.gemstone.tools.GbjDebugger(e);
}
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2. Have the application open a GbjLauncher so you can set the breakpoint, 
which must be set within the session in which the application is running. This 
example opens the Launcher only when the system property mydebug is 
true. The object session is an instance of GbjSession.

if (Boolean.getBoolean("mydebug"))
new GbjLauncher(session);

3. Start the application. When the Launcher appears, open a source code browser 
and set the breakpoint as explained in the previous topic. For our example, the 
command line is

4. Run the part of the application that calls the Smalltalk code where the 
breakpoint is set. When the breakpoint is encountered, the debugger will 
open.

Figure 3.7   Debugger Invoked from a Running Application

You can step through the Smalltalk execution as desired. Because the client Java 
thread is not suspended, however, it continues execution and may encounter a 
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NullPointerException on a object that was not returned from the GemStone 
server.
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Common Menus and Shortcuts
All text panes in all GemBuilder for Java tools have a popup menu allowing you 
to perform common operations. The popup menu differs slightly, depending on 
which tool the text pane belongs to.

To access the popup menu, place the cursor in a text pane and click the right mouse 
button. To dismiss the popup menu without selecting an item, move the cursor off 
the menu and click the left mouse button.

The Popup Menu
The popup menu items are:

Cut Cuts the selected text and places it in the clipboard.
Copy Copies the selected text and places it in the clipboard.
Paste Pastes the text from the clipboard at the current insertion 

point.
Select All Selects all the text in the pane.
Do-It Uses the GemStone compiler to evaluate the currently 

selected text.
Print-It Performs a Do-It, sends the resulting object the message 

printString, and then places the resulting string after the 
current text pane selection.

Inspect-It Performs a Do-It, then opens a GemStone Inspector on the 
resulting object.

Compile Compiles the selected source code. This menu item is 
available only in those tools for which it is relevant.

Cancel Cancels any text you entered in the text pane, returning it to 
its unmodified form. This menu item is available only in 
those tools for which it is relevant.

Set Break Sets a breakpoint at the current insertion point in the 
current method. This menu item is available only in those 
tools for which it is relevant.
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Keyboard Shortcuts
The following keyboard shortcuts are available:

Edit > Cut Control-X
Edit > Copy Control-C
Edit > Paste Control-V
Edit > Select All Control-A
Edit > Do-It Control-D
Edit > Print-It Control-P
Edit > Inspect-It Control-I
Edit > Compile Control-S
Session > Commit Control-Shift-S
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A
Abort (menu item) 15, 22, 37, 39
Add (menu item) 23, 25

B
Begin (menu item) 22, 37, 39
Breakpoint Browser 31

opening 16
breakpoints 31, 40

buttons 32
Breakpoints (menu item) 16
Browse Class (menu item) 16, 23
Browse Hierarchy (menu item) 16, 23
Browse Method (menu item) 25
Browse Versions (menu item) 23
Browser (menu item) 16
Browser button 13, 19
browsers, specialized 27

browsing
classes 16
hierarchy 16
references 16

buttons
Browser 13, 19
Implementors 13
in Debugger 42
Login 13
Logout 13
Senders 13
Workspace 13

C
Cancel (menu item) 22, 39, 47
Class Browser 16, 23, 27

description 27
Class menu 23
Class Version Browser 23, 29

description 27
CLASSPATH 10

Index
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Close (File menu item) 21, 36, 38
Comment (menu item) 24
Commit

keyboard shortcut 48
Commit (menu item) 15, 22, 37, 39
Compile

keyboard shortcut 48
Compile (menu item) 22, 39, 47
Continue (button) 42
Continue (menu item) 42
Copy

keyboard shortcut 48
Copy (menu item) 15, 21, 36, 38, 47
Copy Stack (menu item) 43
Cut

keyboard shortcut 48
menu item 15, 21, 36, 38, 47

D
Debugger 35, 40–46

invoking from java client 44
invoking from workspace 43
menu items 42–43

Definition (menu item) 24
Dictionary menu 23, 27
Dictionary, inspecting 39
Do-It

keyboard shortcut 48
Do-It (menu item) 15, 21, 37, 38, 47

E
Edit menu 15, 21
environment variables 10
executing code 15
Exit (menu item) 14
Explain (menu item) 42

F
File In (File menu item) 14, 36
File It In (menu item) 15, 37

File menu 14, 21
File Out As (menu item) 23, 25
filing in code 15, 37
Find Class (menu item) 23
Find Method (menu item) 25
Find Substring (menu item) 16

G
Gem Service 12
GemStone Browser 13, 27

description 19

H
Hierarchy (menu item) 24
Hierarchy Browser 16, 23, 27

description 28

I
Implementors (menu item) 16, 25
Implementors button 13
Inspect (menu item) 23, 39, 43
inspecting objects 15
Inspect-It

keyboard shortcut 48
menu item 15, 22, 37, 47

Inspector 15, 20, 37–40
description 37
menu items 38–39

instance variables
inspecting 38

K
keyboard shortcuts 48

L
Launcher 19, 27

description 12
using 10
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Login (menu item) 15
Login button 13
Logout

button 13
Logout (menu item) 15

M
Method Browser 25

description 30
Method List Browser 13, 16, 25, 27

description 30
Method menu 25
More (menu item) 39
Move to (menu item) 24

N
NetLDI 12
New Template (menu item) 24

O
Open (File menu item) 14, 36

P
Paste

keyboard shortcut 48
Paste (menu item) 15, 21, 36, 38, 47
popup menu 47
Print-It

keyboard shortcut 48
Print-It (menu item) 15, 22, 37, 38, 47
Process menu 42
Protocol menu 25

R
References (menu item) 16
References To > Class (menu item) 24
References To > Instance Variable 

(menu item) 23

Remove (menu item) 23, 24, 25
Rename As (menu item) 23, 25

S
Save As (File menu item) 14, 36
Select All

keyboard shortcut 48
Select All (menu item) 15, 21, 36, 38, 47
Senders (menu item) 16, 25
Senders button 13
Session menu 15, 22
Set Break (menu item) 22, 47
set, inspecting 40
Settings (menu item) 14
shortcuts, keyboard 48
Step Into (menu item) 42
Step Over (menu item) 42
string, searching for 16
symbol dictionaries 20
System Browser (GemStone Browser) 

19

T
Tools menu 16
Transaction Mode 12, 15

automatic 15
manual 15

transaction, beginning 15
Trim Stack (menu item) 43
Trim Stack button 42

U
Update (menu item) 21, 38

W
wildcards 14, 16, 27, 30
Workspace 12, 35, 36–37

button 13
launcher menu item 16
menu items 36–37
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